summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorHombreLaser <buran@silosneeded.com>2024-06-09 17:44:39 -0600
committerHombreLaser <buran@silosneeded.com>2024-06-09 17:44:39 -0600
commit765c8e55f206637ee0a5948f34f0ebfe9acd7d86 (patch)
tree88712bd4db68a09348f95f6fd29bdaef13a0c7f9 /examples/CMakeLists.txt
parentd9300dbeac7178f7d74e851d3d9c0b4c990faac6 (diff)
Add examplesHEADmaster
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..572df7e
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 3.12)
+
+include($ENV{PICO_SDK_PATH}/external/pico_sdk_import.cmake)
+
+project(keypad_example C CXX ASM)
+
+pico_sdk_init()
+
+add_library(keypad ../src/keypad.cpp ../src/keypad.hpp)
+
+add_executable(keypad_example keypad_example.cpp)
+
+target_include_directories(keypad_example PUBLIC ../src)
+
+# Serial output.
+pico_add_extra_outputs(keypad_example)
+
+target_link_libraries(keypad pico_stdlib hardware_gpio)
+
+target_link_libraries(keypad_example keypad hardware_timer)
+
+add_compile_options(-O0)