summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 89b60e6..9265ad8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -11,7 +11,16 @@ target_include_directories(Pico-I2C-LCD INTERFACE ../libs/Pico-I2C-LCD/)
target_include_directories(Pico-I2C-LCD PUBLIC ../libs/Pico-I2C-LCD/)
# Main executable
-add_executable(pico-calc pico-calc.cpp calculator.cpp tokenizer.cpp)
+add_executable(pico-calc pico-calc.cpp
+ calculator.cpp
+ tokenizer.cpp
+ operand.cpp
+ syntax_tree.cpp
+ sum.cpp
+ substraction.cpp
+ product.cpp
+)
target_link_libraries(pico-calc
hardware_i2c Pico-I2C-LCD pico-keypad hardware_timer)
target_include_directories(pico-calc PUBLIC include exceptions)
+pico_add_extra_outputs(pico-calc)