summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHombreLaser <buran@silosneeded.com>2024-06-22 16:45:04 -0600
committerHombreLaser <buran@silosneeded.com>2024-06-22 16:45:04 -0600
commit404826e78a56e15e20d3938aed80945295921745 (patch)
treed607769fccfc4e3c77a9465a9800004421c500cb /src/CMakeLists.txt
parent10ecf4d95194a273cc6aab89c3a1bcf739a194cd (diff)
Add parser
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 89b60e6..9265ad8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -11,7 +11,16 @@ target_include_directories(Pico-I2C-LCD INTERFACE ../libs/Pico-I2C-LCD/)
target_include_directories(Pico-I2C-LCD PUBLIC ../libs/Pico-I2C-LCD/)
# Main executable
-add_executable(pico-calc pico-calc.cpp calculator.cpp tokenizer.cpp)
+add_executable(pico-calc pico-calc.cpp
+ calculator.cpp
+ tokenizer.cpp
+ operand.cpp
+ syntax_tree.cpp
+ sum.cpp
+ substraction.cpp
+ product.cpp
+)
target_link_libraries(pico-calc
hardware_i2c Pico-I2C-LCD pico-keypad hardware_timer)
target_include_directories(pico-calc PUBLIC include exceptions)
+pico_add_extra_outputs(pico-calc)